+ Ответить в теме
Страница 1 из 7 123456 ... ПоследняяПоследняя
Показано с 1 по 10 из 67

Тема: Debian ?

  1. #1
    туземец Auduf Путь к славе только начался Аватар для Auduf
    Регистрация
    27.11.2007
    Сообщений
    15
    Поблагодарил(а)
    0
    Получено благодарностей: 0 (сообщений: 0).

    По умолчанию Debian ?

    Взялся осваивать lunux, начал с Debian 4.0 Etch (amd64). Поставил, настроил, снёс, опять поставил... ну вы поняли.
    С репо у меня вопрос большой. Старые какие-то там версии все.
    Пример. Boinc уже 5.10.30 стабильный, а в репо только 5.4.11 где-то двухгодовалой давности. Ладно, скачал сам новый, попытался поставить. Требует glibc 2.4, а у меня стоит 2.3.6 и в репо тоже последним числится, хотя поиском нарыл инфу о версии 2.5 от февраля прошлого года. Вручную установить этот 2.5 не осилил, слишком много зависимостей.
    С первого раза пакет ntfs-3g aptitude нашёл и установил, в этот раз какие адреса не прописывал - нету. Скачал поставил вручную, вроде как стоит, но на man не откликается и при загрузке разделы не монтирует.
    Возможно ли и как/какой прописать репозитарий с новым софтом? То что поиск выдаёт пробовал прописывать, тоже самое старьё. Строки были вида
    deb <url> etch main contrib ...
    Может как-то на sid или lenny можно сослаться, как это правильно сделать? Или забить и поставить Ubuntu 7.10 / mandriva 2008?

  2. #2
    старожил Epsilon Жизненный путь еще не решен Аватар для Epsilon
    Регистрация
    14.09.2006
    Сообщений
    2,067
    Поблагодарил(а)
    0
    Получено благодарностей: 0 (сообщений: 0).

    По умолчанию

    Рекомендуется смотреть в сторону Debian sid i386 (ну если у Вас больше 4 гиг памяти, тады 64 бита однозначно)

    И с версиями тут всё хорошо - OpenOffice как-то незаметно стал 2.4 уже

    Если нужен Sid, за ним надо в http://www.sibnet.ru/?apt

    Добавлено через 2 минуты

    Цитата Сообщение от Auduf Посмотреть сообщение
    Или забить и поставить Ubuntu 7.10 / mandriva 2008?
    Сначала всё же стоит попробовать Debian. Если не пойдёт, тогда или Убунту, или Мандриву (но её реп по копейке за мег)
    Эротика с эффектом 25 кадра. Выучи английский с удовольствием.

  3. #3
    Шихан земляк G007 Жизненный путь еще не решен Аватар для G007
    Регистрация
    24.08.2007
    Адрес
    Первомайка
    Сообщений
    1,192
    Поблагодарил(а)
    0
    Получено благодарностей: 0 (сообщений: 0).

    По умолчанию

    Версия дебиана 64 иль ай 389 следует выбирать по процу

  4. #4
    старожил Epsilon Жизненный путь еще не решен Аватар для Epsilon
    Регистрация
    14.09.2006
    Сообщений
    2,067
    Поблагодарил(а)
    0
    Получено благодарностей: 0 (сообщений: 0).

    По умолчанию

    Да ну?

    А то что архитектура amd64 в обычных задачах объёмнее и несколько медленнее?

    У этой архитектуры есть цель: обработка больших объёмов данных. Математики толковой (алгоритмов) для amd64 пока почти нет.

    Как вердикт - на обычном домашнем компе это не надо.
    Эротика с эффектом 25 кадра. Выучи английский с удовольствием.

  5. #5
    здешний Zverushka Путь к славе только начался Аватар для Zverushka
    Регистрация
    30.10.2007
    Сообщений
    161
    Поблагодарил(а)
    0
    Получено благодарностей: 0 (сообщений: 0).

    По умолчанию

    Цитата Сообщение от Auduf Посмотреть сообщение
    Взялся осваивать lunux, начал с Debian 4.0 Etch (amd64). Поставил, настроил, снёс, опять поставил... ну вы поняли.
    С репо у меня вопрос большой. Старые какие-то там версии все.
    вы выбрали СТАБИЛЬНЫЙ релиз Дебиана ...
    так что там и не предпологается чеголибо "самого нового" там предполагается "стабильное из нового на момент релиза" + обновления безопастности...
    Пример. Boinc уже 5.10.30 стабильный, а в репо только 5.4.11 где-то двухгодовалой давности.
    Этчууже год почти ну с момента релиза ...
    с момента заморозки полтора ... всё соответсвует ... ваши ожидания были неоправданны
    Ладно, скачал сам новый, попытался поставить.
    а вот это уже методологически неверный подход
    Требует glibc 2.4, а у меня стоит 2.3.6 и в репо тоже последним числится, хотя поиском нарыл инфу о версии 2.5 от февраля прошлого года. Вручную установить этот 2.5 не осилил, слишком много зависимостей.
    вот вот ... мантейнеры пакетов не просто так - они много чего делают :+)

    С первого раза пакет ntfs-3g aptitude нашёл и установил, в этот раз какие адреса не прописывал - нету.
    Скачал поставил вручную, вроде как стоит, но на man не откликается и при загрузке разделы не монтирует.
    с этим одтдельная песня - выкинули его из репазитария стабильного изза нестабильности или там ещё чего то ...
    Возможно ли и как/какой прописать репозитарий с новым софтом?
    да можно мало то НУЖНО :+) ну имея ввиду ваши цели :+)
    То что поиск выдаёт пробовал прописывать, тоже самое старьё. Строки были вида
    deb <url> etch main contrib ...
    неверный путь решения ваших затруднений ...
    Может как-то на sid или lenny можно сослаться,
    воооо правильное направление мысли :+)
    как это правильно сделать?
    deb http://ftp.ru.debian.org/debian lenny main contrib
    остальные строчки закоментить
    оставив только обновления безопастности секурити дебиан орг в виде:
    deb http://security.debian.org lenny/updates main contrib ...
    apt-get -u update
    apt-get -u upgrade
    apt-get -u dist-upgrade
    и в итоге у вас ленни с последними пакетами для тестируемого (дебиан) дистрибутива от дебиан-тим :=)

    Или забить и поставить Ubuntu 7.10 / mandriva 2008?
    можно забить и оставить виндовс :+)
    убунта этот тотже сид от дебиана ... тока в другой обёртке и с меньшим числом пакетов ...
    ну мандрива это я хз ... не моё ... мой опыт неудачен ... пока :=)

    опять-же, как уже отметил Epsilon, репозитарии для дебиана и убунты в льготной зоне а мандрива за денужку хоть и небольшую но всёже :+)
    Последний раз редактировалось Zverushka; 29.02.2008 в 00:12.

  6. #6
    туземец Auduf Путь к славе только начался Аватар для Auduf
    Регистрация
    27.11.2007
    Сообщений
    15
    Поблагодарил(а)
    0
    Получено благодарностей: 0 (сообщений: 0).

    По умолчанию

    Релиз я не выбирал, мне на какой показали тот и скачал.
    Стронно что ntfs-3g выкинули, я записал им около 500 гигов и был вполне доволен. И в мандриве 2008 он в яддре на сколько я знаю...
    Запустил Mandriva 2008 One с диска - всё работает, поставил на винт - загружается и виснет намертво. Разбираться с ней желания нет, хочу обратно Дебиан.
    Разве Debian Etch 4.0 r2 больше года?
    Т.е. вывод-то какой, нужно качать новый дистриб debian-testing или можно прописать другие репо и обновить этот ("apt-get -u dist-upgrade")?

    Относительно стоимости - у меня анлим.

  7. #7
    старожил Epsilon Жизненный путь еще не решен Аватар для Epsilon
    Регистрация
    14.09.2006
    Сообщений
    2,067
    Поблагодарил(а)
    0
    Получено благодарностей: 0 (сообщений: 0).

    По умолчанию

    Можно обновить
    У меня дистриб убунты - 5.10, из первых которые рассылали
    Ставил её, потом обновлялся.
    Сейчас вообще ставлюсь с Debian NetInst

    Добавлено через 58 секунд

    Цитата Сообщение от Auduf Посмотреть сообщение
    Относительно стоимости - у меня анлим.
    В случае Debian/Ubuntu - клиентам СТК бесплатно (при использовании sibnet.ru/?apt)
    Эротика с эффектом 25 кадра. Выучи английский с удовольствием.

  8. #8
    туземец Auduf Путь к славе только начался Аватар для Auduf
    Регистрация
    27.11.2007
    Сообщений
    15
    Поблагодарил(а)
    0
    Получено благодарностей: 0 (сообщений: 0).

    По умолчанию

    Цитата Сообщение от Epsilon Посмотреть сообщение
    Можно обновить
    У меня дистриб убунты - 5.10, из первых которые рассылали
    Ставил её, потом обновлялся.
    Сейчас вообще ставлюсь с Debian NetInst
    А как действует NetInstall? Сразу можно выбрать что ставить, или сначало только ядро, а потом через консоль и atp-get?

  9. #9
    старожил Epsilon Жизненный путь еще не решен Аватар для Epsilon
    Регистрация
    14.09.2006
    Сообщений
    2,067
    Поблагодарил(а)
    0
    Получено благодарностей: 0 (сообщений: 0).

    По умолчанию

    Ставится ядро с небольшим количеством софта (около 100 мегабайт), а дальше консоль

    Моя домашняя система сделана как раз так.

    Нафиг качать тестируемый дистриб, если всё равно почти все пакеты из него надо обновлять?
    Эротика с эффектом 25 кадра. Выучи английский с удовольствием.

  10. #10
    здешний Zverushka Путь к славе только начался Аватар для Zverushka
    Регистрация
    30.10.2007
    Сообщений
    161
    Поблагодарил(а)
    0
    Получено благодарностей: 0 (сообщений: 0).

    По умолчанию

    Цитата Сообщение от Auduf Посмотреть сообщение
    Т.е. вывод-то какой, нужно качать новый дистриб debian-testing или можно прописать другие репо и обновить этот ("apt-get -u dist-upgrade")?
    не совсем...
    вобщем рельаность такова ...
    можно поставить стабильный релиз дебиана...
    потом ссо временем столкнуться с необходимостью пользоватся более новым совтом (и вас не парит его -софта- возможная нестабильность), в дебиане МОЖНО в качестве репозитория прописать тот репозиторий, который относится например к тестируемой версии дебиана
    и использовать их в качестве основы для инсталяции софта
    тоесть мы вместо
    deb http://asdfasdfasdfsadf/debian stable main
    прописываем
    deb http://asdfasdfasdfsadf/debian testing main
    делаем
    apt-get update
    и дале или обновляем тот софт что стоит или просто ставим тот что нам нада ...
    :+)
    а вот дист-апгрейд после апдейта и агрейда софта
    заменяет основные системные библиотеки ядро и прочеее на то что соответствует тестируему дистрибутиву и соответсвтенно у вас уже НЕ стейбл а тестинг полноценный :+)

    вощем есть такое - апт хауту рекомендую для прочтения ...


    теперь если вы используете установочный диск (нетинстал или первый сиди/идвиди) от тестируемого дистрибутива то соответсвенно вам дист-апгрейд делать не нужно :+)

+ Ответить в теме
Страница 1 из 7 123456 ... ПоследняяПоследняя

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения